Algae appearing

Get help on those urgent fishkeeping problems!

Algae appearing

Postby peter212693 » Thu Oct 04, 2012 8:22 pm

Hello all,

My tank has been cycled for a couple of months nearly and my brown dusty type algae is starting to go away which is good. Over the last couple of days I have spotted this type of algae growing on a couple of the ornaments. Its like a black / very dark green colour and kind of looks like a little tree.

My water conditions are all fine:

Ammonia 0
Nitrite 0
Nitrate 10-20

My tanks is a 200l and I do weekly 30% water changes.

Any help with identification and tips to remove would be great!

Lights are on for 6 hours a day.

Many Thanks

Image
Image
Image
Image

Pics are not the best but its quite small so was hard to get a picture of!
12 Neon Tetras
8 Rummynose Tertas
1 Bristlenose Plec
5 Cherry Barbs (2 Males 3 Females)
6 Five Banded Barbs
6 Zebra Danios
5 Harlequin Rasboras
6 Zebra Loaches
peter212693
Member
 
Posts: 96
Joined: Sat Jul 07, 2012 9:01 pm

Re: Algae appearing

Postby englishmx » Fri Oct 05, 2012 12:20 am

Peter that's Black hair algae

Have a search via Google, heaps of different tips and solutions to try
Mike...
User avatar
englishmx
Member
 
Posts: 1144
Joined: Sun Nov 04, 2007 6:17 pm
Location: South West

Re: Algae appearing

Postby Carylnz » Mon Oct 08, 2012 7:39 am

My home forum is The NZ Fishroom http://www.fnzas.org.nz
User avatar
Carylnz
Moderator
 
Posts: 7478
Joined: Thu Jun 14, 2007 7:37 pm
Location: Blenheim, NZ


Return to Help!

Who is online

Users browsing this forum: No registered users and 5 guests

cron