plant problems

A forum for plants and all aspects of planted aquariums.

plant problems

Postby IndianoAnnie » Mon Jan 28, 2013 11:13 pm

HI, I have noticed the past couple of months that some of my plants are becoming brown in places and some leaves are going browny and kind of transparent. I have been using API leaf zone once a week when carrying out water changes but i have recently stopped this incase im using too much. Any advice :) ?
Thanks,
Annie :)

55L planted
Red cherry shrimp
Cycled
Newbie-ish :)
IndianoAnnie
Member
 
Posts: 151
Joined: Thu Sep 06, 2012 1:37 pm
Location: County Durham, North East

Re: plant problems

Postby ady » Tue Jan 29, 2013 9:01 am

What plants do you have ?.

Mite be worth trying some substrate food tablets.

Although be careful with them if you got shrimp because
they contain copper traces.
This is still under debate but better to be safe than sorry.

I just had to catch my cameroon shrimp before i added food tabs
to the gravel.that was fun!!.
humans are the only race,with the intelligence to save the earth...shame we have the ignorance to ignore the salvation!!!!!
ady
Member
 
Posts: 843
Joined: Wed Jan 05, 2011 11:53 am
Location: suffolk

Re: plant problems

Postby IndianoAnnie » Tue Jan 29, 2013 12:39 pm

the plants that are having the problem is vallis and sword.. i have tried to look for other food but most dont tell you if they have copper :/
Thanks,
Annie :)

55L planted
Red cherry shrimp
Cycled
Newbie-ish :)
IndianoAnnie
Member
 
Posts: 151
Joined: Thu Sep 06, 2012 1:37 pm
Location: County Durham, North East

Re: plant problems

Postby ady » Tue Jan 29, 2013 5:33 pm

Both are root hungry feeders.my swords have just been given root tabs.
Should make em grow like mad.

I got mine off of ebay.2large cones for £2.35inc delivery,last 6 months
apparently..

Do u have shrimp then ?
humans are the only race,with the intelligence to save the earth...shame we have the ignorance to ignore the salvation!!!!!
ady
Member
 
Posts: 843
Joined: Wed Jan 05, 2011 11:53 am
Location: suffolk

Re: plant problems

Postby IndianoAnnie » Tue Jan 29, 2013 5:36 pm

yeah i have a shrimp only tank, there my babies. I looked at the root tab things before but Im wary with me having shrimp
Thanks,
Annie :)

55L planted
Red cherry shrimp
Cycled
Newbie-ish :)
IndianoAnnie
Member
 
Posts: 151
Joined: Thu Sep 06, 2012 1:37 pm
Location: County Durham, North East

Re: plant problems

Postby ady » Tue Jan 29, 2013 5:38 pm

You can get food in substrate form.under the gravel stuff.

But that does mean removing everything and replanting when u done

Seen some amazons and vallis planted with this stuff and they huge
Specimins.when i get new tank i shall be using it.
humans are the only race,with the intelligence to save the earth...shame we have the ignorance to ignore the salvation!!!!!
ady
Member
 
Posts: 843
Joined: Wed Jan 05, 2011 11:53 am
Location: suffolk

Re: plant problems

Postby ady » Tue Jan 29, 2013 5:39 pm

If shrimp only,hopefully a planted shrimp tank owner can advise you further..
humans are the only race,with the intelligence to save the earth...shame we have the ignorance to ignore the salvation!!!!!
ady
Member
 
Posts: 843
Joined: Wed Jan 05, 2011 11:53 am
Location: suffolk


Return to Plants and Planted Aquariums

Who is online

Users browsing this forum: Google [Bot] and 1 guest